PHP 5.3 Support ?

News rund um NetBeans und PHP

Moderator: wegus

Antworten
Benutzeravatar
wegus
Beiträge: 458
Registriert: 26.09.2006, 09:07

PHP 5.3 Support ?

Beitrag von wegus » 01.04.2009, 14:12

ich weiß, keine News - mehr eine Frage:

PHP hat für 5.3 einen ersten RC veröffentlicht:

http://www.php.net/archive/2009.php#id2009-03-24-1

das Thema exakte Syntax für Namespaces scheint damit durch und durch die deutlichen Änderungen in 5.3 wird der Bedarf nach einer unterstützenden IDE steigen.

Weiß jemand wie der Stand bei Netbeans 6.5s PHP Plugin ist? Wird es da ein Update für PHP 5.3 geben in nächster Zeit? Ich würde ja gern mal die Neuerungen testeb die sich damit ergeben.
Wenn etwas zu einfach klingt um wahr zu sein, dann ist es oft auch nicht wahr!

Benutzeravatar
arittner
Beiträge: 3229
Registriert: 05.08.2008, 07:20
Wohnort: Südniedersachsen
Kontaktdaten:

Beitrag von arittner » 02.04.2009, 07:09

Moin!

http://wiki.netbeans.org/FeaturesForPHPV1

Und PHP V1 ist m.E in NetBeans 6.7

Beste Grüße,
Josch.
JNBB/BeanDev-Blog | Twitter@beandev
Bild
Sun Certified Specialist for NetBeans IDE

Benutzeravatar
wegus
Beiträge: 458
Registriert: 26.09.2006, 09:07

Beitrag von wegus » 02.04.2009, 09:57

Danke :!:

EDIT:

Nein leider nicht! Ich habe jetzt PHP5.3RC1 mit Xdebug 2.0.4 unter OS X laufen und mir den tagesaktuellen Entwicklerbuild gezogen. Leider wird die PHP 5.3 Syntax nicht erkannt. Es ist aber ein 5.3 PHP in der IDE eingetragen von mir.

Daraus schliesse ich das noch kein PHP 5.3 unterstützt wird. Schade...
Wenn etwas zu einfach klingt um wahr zu sein, dann ist es oft auch nicht wahr!

Benutzeravatar
wegus
Beiträge: 458
Registriert: 26.09.2006, 09:07

Beitrag von wegus » 02.04.2009, 12:39

gibt es denn unter Netbeans die Möglichkeit dieses V1-Plugin zum experimentieren einzeln zu laden?

Mit Eclipse und PDT 2.1M6 ist mir das gerade gelungen. Da ich mir ja aber eigentlich die zusätzlichen angenehmen Features der Netbeans IDE zu Nutze machen wollte würde ich das gleich gern entsprechend testen.

Leider bin ich da aber nicht up to date! Any chance for me? Oder muß ich mich schlicht noch ein wenig gedulden?
Wenn etwas zu einfach klingt um wahr zu sein, dann ist es oft auch nicht wahr!

Antworten